Page tree
Skip to end of metadata
Go to start of metadata

Review the prerequisites for using eRoom Connector.

On this page:

Version of eRoom required


The Aspire eRoom connector was created and tested using version 7.44 with the "Allow XML queries and commands from external applications" option enabled.

Before installing the eRoom connector, make sure that:

  • eRoom server is up and running.
  • The option   "Allow XML queries and commands from external applications" is enabled on the eRoom Site Settings.

User Account Requirements 


In order to access eRoom an user account with sufficient privileges must be supplied. It is recommended the account be the site administrator.

Get An User Account

To set the rights for your "aspire_crawl_account", do the following:

  • Log into the eRoom Server as an Administrator.
  • Click on Site Settings.
  • Click on General.
  • Click on Members icon in "Site Administrator" section.
  • Click on "aspire_crawl_account" or click on add to create a new one.
  • Make the role of the "aspire_crawl_account" either site administrator and community administrator (so that it has access to all eRoom content).

You will need this login information later in these procedures, when entering properties for your eRoom Connector.

Windows or Linux


The eRoom connector runs on either Windows or Linux.

It uses the XML/SOAP API to communicate with Eroom server.

eRoom services used are:

  • XML queries and commands from external applications (You can enabled in the ERSAdmin console or in the site settings).

These services should be started and running automatically if eRoom is up and running. These are required for the Aspire eRoom Connector to successfully connect with the eRoom docbase that you want to index.


  • No labels