Page tree
Skip to end of metadata
Go to start of metadata

Aspire 4.0 is integrated into the Hadoop ecosystem as a Cloudera parcel with Accenture AIP.  However, you can still use Aspire in stand-alone mode or as a parcel inside of Cloudera.

Find more information on the Cloudera parcel configuration at Aspire Parcel and Service for Cloudera.

A logical consequence of the integration into the Hadoop ecosystem is the support for HBase for crawl metadata and statistics (previously only MongoDB was supported). This facilitates the use of Aspire as part of Big Data solutions.

The supported java version for Aspire 4.0 is Java 11, with one exception, for HBASE as NoSQL provider the supported version would be Java 8.

Use Case Example

Review a  relevant use case success here. Extended support necessitated refactoring the connector framework and implementing improvements over the previous Aspire version (3.x).

All configuration steps needed to configure HBase for crawl metadata can be found at HBase Settings.

Other features of interest are Licensing and User Roles. User roles improve security control by separating users into "Developers" and "Administrators" with different roles and permissions over the Aspire configuration.

See Aspire 4.0 Release Notes for more technical information about this release.


Migrating from Aspire 3.x

When importing a content source from 3.x into 4.0, the following error may occur. The content source may show up with a red "Failed" status.

Error message: Unable to start appBundle: com.searchtechnologies.aspire:app-rap-connector
Caused by: com.searchtechnologies.aspire.services.AspireException: Failed to register components from appBundle: CONTENT_SOURCE_NAME (Parent: <null>)
	at com.searchtechnologies.aspire.application.AspireApplicationImpl.registerAppBundleComponents(AspireApplicationImpl.java:945)
	at com.searchtechnologies.aspire.application.AspireApplicationImpl.registerAppBundle(AspireApplicationImpl.java:980)
	at com.searchtechnologies.aspire.application.AspireApplicationComponent.loadApplication(AspireApplicationComponent.java:696)
	at com.searchtechnologies.aspire.application.AspireApplicationComponent.loadApplication(AspireApplicationComponent.java:692)
	at com.searchtechnologies.aspire.configuration.ConfigurationManager.reloadApplication(ConfigurationManager.java:697)
	at com.searchtechnologies.aspire.configuration.ContentSourcesModule.processSyncUnitUpdate(ContentSourcesModule.java:309)
	at com.searchtechnologies.aspire.configuration.SynchronizedModule.run(SynchronizedModule.java:289)
	at java.lang.Thread.run(Thread.java:748)
Caused by: com.searchtechnologies.aspire.services.AspireException: The value ("${waitForWfApps}") of element <waitForWfApps> is improperly formatted for a boolean - must be either "true" or "false"
	at com.searchtechnologies.aspire.framework.ComponentImpl.getBooleanFromConfig(ComponentImpl.java:2634)
	at com.searchtechnologies.aspire.connector.framework.controller.CrawlControllerImpl.initialize(CrawlControllerImpl.java:260)
	at com.searchtechnologies.aspire.framework.ComponentFactoryImpl.registerComponent(ComponentFactoryImpl.java:446)
	at com.searchtechnologies.aspire.application.ComponentManagerImpl.registerComponents(ComponentManagerImpl.java:328)
	at com.searchtechnologies.aspire.application.ComponentManagerImpl.initialize(ComponentManagerImpl.java:93)
	at com.searchtechnologies.aspire.application.PipelineManagerImpl.initialize(PipelineManagerImpl.java:75)
	at com.searchtechnologies.aspire.framework.ComponentFactoryImpl.registerComponent(ComponentFactoryImpl.java:446)
	at com.searchtechnologies.aspire.application.ComponentManagerImpl.registerComponents(ComponentManagerImpl.java:328)
	at com.searchtechnologies.aspire.application.ComponentManagerImpl.initialize(ComponentManagerImpl.java:93)
	at com.searchtechnologies.aspire.framework.ComponentFactoryImpl.registerComponent(ComponentFactoryImpl.java:446)
	at com.searchtechnologies.aspire.application.AspireApplicationImpl.registerAppBundleComponents(AspireApplicationImpl.java:941)


This could happen because Aspire 4.0 connectors contain configuration options that the "content source to import" lack.  To fix this error:

  1. Click on the content source to access the Configuration page.
  2. Click Save and Done.

Aspire generates the new options and saves them into the configuration files.

  • No labels